The sharing feature is currently partially unavailable.
Resolved
Jun 25, 2026 at 12:30pm UTC
We have started rolling out a mitigation for the email delivery issue affecting Microsoft-hosted recipients.
The sharing feature should now be working again for newly shared documents as the update is progressively deployed.
We will continue to monitor delivery closely while working with Microsoft to have app.there.do recognized as a safe domain and prevent similar false positives in the future.
Affected services
Updated
Jun 24, 2026 at 10:28am UTC
We have identified the root cause of the email delivery issue affecting Microsoft-hosted recipients (Outlook.com, Hotmail, Exchange Online, and Microsoft 365).
Microsoft Defender is currently flagging links to app.there.do as phishing links, causing some of our sharing notification emails to be filtered or blocked before reaching recipients.
We are currently deploying a mitigation that removes these links from affected emails to avoid the false positive and restore reliable delivery.
At the same time, we are working with Microsoft to have app.there.do reviewed and recognized as a safe domain.
We will continue to monitor delivery rates and provide further updates as the mitigation is deployed and Microsoft completes its review.
Affected services
Created
Jun 23, 2026 at 2:02pm UTC
We have identified an issue affecting emails sent to recipients whose mail is hosted on Microsoft services (such as Outlook, Microsoft 365, Exchange, and Hotmail). In these cases, documents may not be received even though the share action is reported as successful.
While we investigate and resolve the issue, we recommend generating a PDF and sending the document manually to recipients.
We apologize for the inconvenience and will provide an update as soon as the issue is resolved.
Affected services